Wednesday, May 2, 2018

72.9

Fix to size of workdir not within allowed limit
- Remeasuring size of workdir after removing input files to fix a bad log message and esp. to avoid sending a wrong value to job metrics
- Requested by R. Walker

Zipmapping
- After pilot+server+rucio updates, Archive_tf can now be used as intended (zips input files, server knows about metadata already)
- First we tested skipping Archive_tf since it packed files before pilot could create metadata, then we let pilot create the archive.
Turned out that server couldn’t handle additional metadata since it believed it came from skipped input files (old mechanism)

Fix for Harvester kill worker
- Requested by F. Lin

Using rucio API for stage-out when rucio upload fails
- Previous problems with exceptions in the client have been resolved (by T. Wegner)

Event service
- Removed postExec AthenaMP option for PoolFileCatalog

Fix added after the ADC Weekly meeting:
- Now setting proper pilot error code in case of lsm stage-in failures due to checksum verification issues.

Code contributions from W. Guan, T. Javurek, A. Anisenkov, P. Nilsson.

No comments: