Summary
- A bug was introduced in v 64.0 that prevented the skipping stage-in of locally available DBRelease files; i.e. these files were staged in as normal files. This was discovered by Asoka De Silva yesterday where some user jobs failed to run because the latest DBRelease file (30.0.1) was not available in the file catalog locally, causing the pilot to fail stage-in.
- Removal of code for allowing missing input files to be skipped during stage-in. This mechanism is very old and is not relevant any longer since we now have FAX failover as well as job retry. A problem discovered today with the aCT lead to complications in the pilot which did not find some of the input files, causing said files to end up in the missing files XML. These files are added to the final XML sent to the server, but caused a ND script to stumble due to the presence of unexpected files in the XML, which in turn made debugging unnecessarily difficult.
Version info
General change
- Prevented outdated skipping of missing input files, to avoid complications seen on ND when one skipped file is a log file, in sitemover_get_data() (M\
over)
Bug fix
- Removed tmp return from handleDBRelease() which caused skipping of DBRelease file to fail (Mover)
No comments:
Post a Comment